WordPress 5.0 met omstreden Gutenberg-editor

Noud van Kruysbergen
0

WordPress 5.0 Bebo is geen gewone update. Er waren van tevoren al veel discussies over. Versie 5.0 heeft in plaats van de klassieke WordPress-editor TinyMCE namelijk een nieuwe editor met de naam Gutenberg.

Die is sinds begin 2017 door WordPress zelf ontwikkeld. Gutenberg deelt berichten en pagina’s in blokken in, die met de editor makkelijk aan te passen zijn: een blok voor de titel, een voor de eerste alinea, een voor een afbeelding en zo verder. De blokken zijn te verplaatsen, verwijderen en afzonderlijk te configureren.

Volgens WordPress-uitvinder Matt Mullenweg “kun je daar veel flexibeler mee werken”. De op blokken gebaseerde editor moet het vormgeven van WordPress-pagina’s vergemakkelijken, maar veel gebruikers waren en zijn sceptisch. Vanuit de community waaide een stevige tegenwind. Door Gutenberg verandert de manier waarop bijdragen gemaakt worden drastisch, en niet iedereen is daar blij mee. Mullenweg verklaart in zijn blog: “Er is altijd wat angst voor grote veranderingen, maar die leiden wel tot een doorontwikkeling.” Het is nu een mooi moment om een ontwikkeling door te zetten die het populaire contentmanagementsysteem geschikt moet maken voor de toekomst.

Veel kritiek op Gutenberg

Critici vinden het uitkomen van Gutenberg en WordPress versie 5.0 echter te vroeg komen, volgens hen had de testfase langer moeten duren. Dan hadden de talrijke theme- und plug-in-ontwikkelaars meer tijd gehad hun producten compatibel met Gutenberg te maken.

De Gutenberg-extensie, die maanden voor de feitelijke release als testballon diende, werd in het plug-in-overzicht afgestraft met een beoordeling van één ster. De verantwoordelijke WordPress-ontwikkelaars trokken zich de geuite kritiek aan en reageerden omvangrijk op opmerkingen vanuit de community. De update naar versie 5.0 werd daarnaast meermaals verschoven om een overstap zo soepel mogelijk te laten verlopen.

Klassieke editor blijft beschikbaar als plug-in

WordPress biedt gebruikers die geen afscheid van de klassieke editor kunnen of willen nemen de plug-in Classic Editor. WordPress zal de klassieke editor tot 2021 ondersteunen.

Voor een update naar versie 5.0 moeten gebruikers een back-up van hun website maken om in geval van nood terug te kunnen keren naar een oudere versie. Je moet bovendien controleren of het geïnstalleerde theme en de geactiveerde plug-ins compatibel zijn met Gutenberg. Het kan zijn dat je short-codes gebruikt waar de nieuwe editor niets mee kan. Als je een zakelijke website beheert of een online shop en geen uitval wilt riskeren, moet je versie 5.0 eerst in een testomgeving uitproberen om daar achter eventuele fouten te komen. Doe dat in alle rust, en laat je vooral niet opjagen.

WordPress 5.0 bevat het nieuwe standaard-theme Twenty Nineteen, dat Gutenberg compleet ondersteunt. Het theme is redelijk minimalistisch met een aardige typografie. Ook de oudere standaard designsjablonen tot en met Twenty Ten zijn geschikt voor Gutenberg. Daarnaast is het CMS nu compatibel met PHP 7.3.

Alle andere vernieuwingen en verbeteringen staan in de release notes. Voor ontwikkelaars staat er meer informatie op de development-blog. De update (overigens genoemd naar de Cubaanse jazzmuzikant Bebo Valdés) is net als voorheen via het beheerdersdashboard te installeren.

Meer over

WordPress

Deel dit artikel

Lees ook

Motorola smartphone met ultragroothoek actioncam

De One Action van Motorola is een smartphone die je als actioncam kunt gebruiken. De ingebouwde ultragroothoekcamera met een zichtveld van 117 graden ...

Veel animo voor c’t testpanel – start eerste test

Er is veel animo voor c't testpanel. De eerste sessie met de Foscam-camera's zit ondertussen vol.

0 Praat mee

avatar
  Abonneer  
Laat het mij weten wanneer er